Logo FreeGlobes

Archive for juin, 2007

MAJ / Update (bug fixes) [ go ]

Salut à tous !

Une petite mise à jour de maintenance du script est disponible. Rassurez-vous, la mise à jour est rapide. Il s’agit de la “Summer release”, pour aborder l’été avec sérénité. La procédure de maj ne concerne bien sur que les personnes ayant deja installé Freeglobes. ^^
Elle corrige :

- Corrections au niveau des fichiers de langues (diverses fautes d’orthographe)
- Optimisations de la rapidité d’affichage grâce au nettoyage d’une partie du code
- Amélioration de la classe Dir qui gère l’optimisation des tables du script, Ajout de la classe Powered

Si vous avez deja Freeglobes 05.05.2007-RC2, Télécharger l’archive de Freeglobes disponible dans la section “Télécharger”, puis remplacez les fichiers et dossiers suivants :
- /class/class.dir.php
- /init.php
- /admin/init.php
- /members/init.php
- /language/*/*.php (signifie qu’il faut remplacer tous les fichiers .php présents dans /language/english/, language/french etc… sauf le dossier mail/ de chaque langue)
- /include/common.php
- /include/functions/main.php

English :

If you have Freeglobes 05.05.2007 installed, you can update to 21.06.2007-RC2 release just by replacing all the files listed upper.

[ 1C ] [ 20 juin, 2007 ] [ Actualites ]

Freeglobes 1.0 en préparation [ go ]

Freeglobes 1.0 est actuellement en cours de développement. :-)

Je ne peux pas encore donner de date précise puisqu’il reste pas mal de travail avant la sortie de cette version. Néanmoins, histoire de vous mettre au courant, voici quelques unes des spécifications qu’il faudra impérativement satisfaire pour faire tourner Freeglobes 1.0.
Un hébergement PHP 5.1.4 et supérieur est nécessaire avec les extensions PHP suivantes :
- GD2 (pour générer l’image antibot)
- mbstring
- iconv
- le support des fonctions ob_
- le support utf8
- simpleXML et DomXML

Concernant la base de données il vous faudra MySQL version 4.1 minimum.

Le support PHP4 est officiellement arrêté fin 2007 et les hébergeurs actuels proposent quasiment tous PHP 5. Freeglobes se doit donc d’être dans l’ère du temps en exploitant les dernières technologies disponibles.

La version  1.0 va surtout beneficier d’une jolie avancée au niveau noyau, notamment avec le passage à PHP5. Le moteur de templates Smarty est également remplacé par Template Lite, plus léger mais qui utilise exactement la même syntaxe.

L’editeur Wysiwyg FCKeditor disparait pour laisser place à un editeur Wysiwyg très léger (1kb) qui est un plugin de la librairie Javascript Mootools. Fini les problèmes d’affichage avec cet éditeur !

Pour le reste, je vais garder une part de mystère et vous faire encore patienter quelques temps. ;-)

[ 1C ] [ 6 juin, 2007 ] [ Actualites ]

FosseeneProduct - perdre ses kilos - regimes